Slow response times when adding debit order payment methods during policy issuing
Incident Report for Root
Resolved
This incident has been resolved.
Posted Jan 18, 2020 - 16:45 SAST
Monitoring
A payment service provider of Root is currently experiencing slow response times for check digit verification of bank account details. This is affecting the Root Dashboard, and is causing slow response times and/or timeouts when attempting to add a debit order payment method during policy issuing.

We are continuing to monitor the situation, and will provide an update once the response times have returned to normal.
Posted Jan 18, 2020 - 11:02 SAST
This incident affected: Dashboard.